Blank spaces in credit card numbers

I noticed that Msecure 5 is formatting my credit card numbers with included blank spaces instead of just keeping them as one long string.  For example the numbers are formatted as xxxx xxxx xxxx xxxx instead of xxxxxxxxxxxxxxxx.  This can cause an error when you cut and paste the CC number into some web payment forms because it's retaining those blank spaces.  Even if I edit an entry to remove the spaces, as soon as I save the entry the spaces are returned automatically.  Is there some way I can permanently stop these blank spaces so that copy and paste of CC #'s works without including the spaces?  Msecure 4 did not add blank spaces but version 5 does.

Hi Amy,

Thank you for contacting us and I'm sorry about the issue you're experiencing. Which platform are you using (iOS, Android, Mac, and(or) Windows) and what version(s)? mSecure 5 will include spaces for easier reading of a credit card field. However, when copying the field with our copy icon or option, the space should be removed. If you go into a record, edit it, and try to copy the field that way, you will get the spaces though. Choose the clipboard icon in the details area instead.

This is on Windows 10 using mSecure 5, version 5.5.29.0.  But I think you have solved my problem.  I am apparently subconsciously double-clicking the entry and copying the # that way because I'm used to using Ctrl C/V keyboard shortcuts for copy/paste.  When I just use the copy icon it is indeed copying the number without the blank spaces.  I'll just get used to using the mouse for copying instead of keyboard shortcuts.  Thank you for that info!  I will use this method going forward.  Thanks for the quick reply!

Hi Amy,

So the issue is with double clicking the credit card field in the details view? If so, I can document this issue and see if we can do something about it.

No, the issue is I'm double-clicking the entry itself, which then opens the detail view and puts it into edit mode. (ie: it makes the CC# actually show instead of just showing asterisks)  I'm then putting my mouse in the CC # field, which selects the #, and doing Ctrl C to copy.  So my keyboard shortcut is actually selecting the CC number with the included blank spaces because I'm in edit mode.  If I refrain from double-clicking the entry then I can use the clipboard icon to copy which is fine.  I just didn't realize that when I double-clicked the entry it was putting it in edit mode and including the blanks in my copy.  Make sense?

Yeah, that makes sense. Unfortunately, I can't fix it for this scenario. You'll have to use the UI instead of any shortcut or keys.


Login or Signup to post a comment