Syncing - wrong IP address in MSecure desktop server(Win10) and IOS (Phone/iPad)

In my MSecure desktop (Windows 10) the IP address as listed on the Sync server page is different to that of the laptop where it is physically running... For example:


The IPConfig command states that the IP address of the current machine is 192.168.0.9

MSecure for Windows states that the IP address of THIS server (the current machine) is 192.168.0.13. The iPhone and iPad versions of MSecure also state that the IP address of the server machine is 192.168.0.13 - for obvious reasons, I cannot sync!


My Wi-Fi network is discoverable (Private)

I've tried to re-boot router...


I also had a look at the MSecure 'settings.dat' file and found that it also contains the 192.168.0.13 IP address. In fact, I renamed it and forced MSecure to recreate it. The new version ALSO contains 192.168.0.13. So, where is it getting this from! There is no ....13 IP address on this network!!


Would really appreciate any assistance.


Cheers,


Specs: Win 10, V1803, Build 17134.48. iPhone/iPad (IOS) V 5.5.3 (723)

Have you tried either changing Sync Method to "Don't Syn" and back to WiFi or turning off and on the Main Computer switch?

 Hi Andy, thanks for replying.


Yes, have tried both these options. What I'd really like to know - and probably the answer to my problem...; is where, when, and how is MSecure  getting the IP address of the desktop (server) environment. Further, why this is not editable. Yes, there are some possible security risks this way, but I think this should be in control of the user.


Cheers, Michael

 More for anyone else having this trouble:


I have now partially resolved this issue by getting my DHCP server (at the router) to reserve the IP address that MSecure wants to use.  i.e.


- Login to your router

- Find your attached devices - (see IP address/Mac address)

- Select your machine and reserve the appropriate address, apply the changes, reboot both your machine and router.

- Problem fixed. I can now sync, However...


It still does not resolve this issue.  I could have setup a static IP address, but many use DHCP (home computers etc) and it intrigues me where MSecure could have got that IP address from. The same incorrect IP address was on iPad, iPhone, AND desktop machine (Windows - where the sync server was). MSecure saves some info in the file previously mentioned. However I would have thought it would look for and apply/resolve the IP address for the sync server (and IOS/Android mobile products) dynamically - or is this too much of a security risk? Is the problem that that saved info is not updated?


Cheers,

Good that you have at least (partially) fixed the problem - I have had similar problems (and can't remember how I finally got it sorted out) when the IP address for the primary computer changed - I would have thought mSecure would know which computer was designated as primary and then make the necessary config changes .


Perhaps Eden can let us know the official mSecure reponse.

Hi guys,

mSecure 5 will check your IP address when the "Main computer' option is selected/enabled in the Sync Settings. Unfortunately, there is no way for you to set up a main IP Address or main network adapter for your computer so if you are using multiple network adapters (WiFi and Ethernet for example), mSecure 5 will select the first IP Address it finds. 


If using only a single network adapter,  you can update the IP Address mSecure 5 is using by disabling the "Main Computer" toggle and re-enable the toggle for mSecure 5 to be updated to the computer's current IP Address. 


If using multiple network adapters and mSecure 5 is not selecting the IP Address you need to use, please disable all other network adapters before disabling/enabling the "Main Computer" toggle in the Sync Settings in mSecure 5. That will allow mSecure 5 to select the one IP Address you need. You can re-enable the other network adapters afterwards if needed.


Also, you can always manually assign a static IP Address to your computer without having to use your router:

  1. Control Panel > Network and Internet > Network Connections
  2. Right Click the network adapter you're wanting to change
  3. Click Properties
  4. Click "Internet Protocol Version 4 (TCP/IPv4)
  5. Click Properties
  6. Click "Use the following IP Address"


You'll need to know what the subnet mask (255.255.255.0), default gateway (usually router's IP), and DNS settings should be, but that should be pretty easy to find out (Right click your network adapter's properties > click Status > Click Details). Please note that the IP Address you manually select should be within your router or DHCP device's IP Address range. For example, I have my router set to only use IP addresses (192.168.1.1) from .100 to .199. So I've set my computer's IP Address to be 192.168.1.180. Since it's a static IP Address, my router or HDCP device will not automatically assign my computer another IP Address in the future.

Hi Eden,


"If using only a single network adapter,  you can update the IP Address mSecure 5 is using by disabling the "Main Computer" toggle and re-enable the toggle for mSecure 5 to be updated to the computer's current IP Address."


I did try all this... This would seem to be the obvious answer but it certainly does not work on my computer.


"If using multiple network adapters and mSecure 5 is not selecting the IP Address you need to use, please disable all other network adapters before disabling/enabling the "Main Computer" toggle in the Sync Settings in mSecure 5. That will allow mSecure 5 to select the one IP Address you need. You can re-enable the other network adapters afterwards if needed."


I use a single adapter, the other adapters are always disabled.


MSecure is not updating the IP address although it is told to do so (via server toggle). MSecure is listed as allowed through the Windows firewall. Maybe it has something to do with the file access permissions? You also don't specify whether a MSecure restart, or Windows reboot is required after changing the local sync server. Must admit I haven't tried that yet.

Cheers


Do you have an internet connection when using the toggle? Perhaps you're not allowing mSecure 5 to connect to the internet? In order for mSecure 5 to be able to set up or update your WiFi settings it needs to access to the internet. You don't need internet once the WiFi settings are set or updated.

Hiya, yes always have access to the Internet when using Msecure. When Msecure starts up what housekeeping in regards to the server does it do? Might help me troubleshoot. Also, what about saving the IP address when changed. In a previous message I mentioned the settings.dat file. This was not updated at all that I could see - still had the wrong IP address in it. I'm guessing I'm the only person (or one of very few) having this problem? If so, then I need to figure out what my system is doing/not doing differently. Cheers

Once mSecure 5 has been set with the "Main computer" there shouldn't be any housekeeping needed. However, it seems that if the IP Address for your computer changes, mSecure 5 is not updating the IP Address for the main computer. I will write this up as an issue for our developers to fix. However, you can give your computer a static IP Address so that your router doesn't change your IP Address at any point to avoid this issue.


Login or Signup to post a comment