mSecure Support

Knowledge Base Forums Submit a ticket

Unable to sync via Wi-Fi

Using mSecure 5 with Wi-Fi syncing. Has been syncing fine between my Wndows 10 desktop (set as the main computer) and my iPhone. I added the mSecure 5 app to my Windows 10 laptop and enabled W-Fi syncing but mSecure can't find the network desktop - returns a "Wifi server cannot be reached" error. I can see the desktop computer on the network and access its folders from the laptop.

BTW,  I did see the support article on network settings and everything is set up correctly. And in the app Sync Settings on the laptop the Sync Status shows that the laptop (client) is connected (indicates green) to the desktop (server).

Hi David,

Can you ping each computer here? To run a ping test, first find the IP Address of each computer and follow these instructions:


  1. Open cmd (command prompt) using the Windows search
  2. Ping the IP Address. Example: ping 192.168.1.102


Please let me know your results by either copy/pasting your results or taking a screenshot of the results (Shift+Windows Button+S). I would also recommend making sure that both computer's networks are set to private here: https://m7software.freshdesk.com/support/solutions/articles/36000022762-wi-fi-syncing-issues

Okay, egg all over my face. The pings were okay. Then I realized that I didn't have the mSecure app open on the desktop. As soon as I opened it the laptop synced. Embarrassed. Thanks. Ever consider running the app in the background as a service so that syncs could take place whether the app was open or not?

Hi David,

Yes, we've considered that option. We debated whether we should allow syncing to happen if the app was also locked on a computer as well. However, we settled on having it opened and unlocked at the moment since it's the most common use case for customers. I'm happy to take feedback if you feel it should work differently. 

I think it would be great if that were an option. For those of us who don't use cloud syncing it would allow us to sync across all devices in almost the same way that cloud syncing works - that is, not needing to make a point of having mSecure open and unlocked for syncing to take place. But I wouldn't force it on anyone - I'd make it optional. Thanks for your consideration. Sorry again about the false alarm.

I'm also unable to sync over wifi, but I have the application open on the laptop (MAC) and the iphone.  On the laptop, the "sync" option is not available in the File menu (grayed out).


I've tried it, unsuccessfully, over two different networks - in both cases confirming before the attempt the the laptop and iphone are each individually connecting to the common network.  So, I know there is no generic problem connecting to the network.  


I don't know about this private setting that is mentioned above and can't read the article since that page no longer exists.


I'm extremely frustrated with msecure 5.  I didn't have nearly these issues with the old version.  I waited for the wifi synching to even upgrade and have synched a few times in the past, but this is becoming unacceptable.  Reliable to my passwords is critical, and I haven't had it for weeks since I'm unable to sync the devices.

Here is the article on wifi synching issues that you were looking for but I think it only applies to Windows:


https://m7software.freshdesk.com/support/solutions/articles/36000064491-wifi-syncing-issues


It looks like the support articles links have changed

Hi Julia,

Thank you for contacting us and I'm sorry about the issue you are experiencing. The Wifi sync issues article covers a very common Windows issue with network profiles. As for why the sync option is grayed out on your computer.


The syncing in mSecure is set by default to be triggered automatically, and a manual sync can be initiated only on a "client" device. On your computer you will not be able to perform a manual sync. Your desktop computer is what is known as a "server", which is the computer with which the "client" devices initiate communication. In the mSecure sync settings on your desktop, you will see a checkbox called "Main Computer", which is just a more approachable way of saying it's a "server," as many people don't know this type of technical lingo. A "server" just sits on the network and waits for the clients to connect with it. 


In the case of mSecure, the clients communicate with the server to TELL it a sync is necessary if the client knows it has changes to sync over to the server, and it also ASKS the server if there are changes to sync in to the client. The server will never tell the client anything. Again, it's just sitting on the server waiting to be interacted with by one of the client devices.


This is the reason why there is no manual sync functionality in mSecure on your desktop. It's the server, so it cannot tell the client anything, and the sync option in the menu at the top of the screen will always be grayed out. All syncing is initiated from the client, not the other way around.


To manually sync on iOS, please have at least one record on iOS or create a test record and follow these steps:

  1. Tap and hold the top record
  2. Drag the record down and release


My first recommendation when running into WiFi syncing issues is to restart your router and devices and try again. Please let me know if that doesn't fix your issues and I'll be happy to walk you through other steps to test your local network and hopefully fix whatever the computer or network issue you are running into is.

Also, thanks Andy!

This was not helpful.  I had already tried all of that since that information is available in the online help.

Hi Julia,

I'm sorry that explaining how servers and clients didn't help you here. We don't actually have any documentation stating that information so I'm not sure what you mean with your response here. Wi-Fi syncing can be very complicated because of different local network setups. My first recommendation, besides posting an issue in the correct section (this is a Windows wifi topic) is always to restart your router and devices and try again. However, other useful steps are:


1. Turn off and on the "Main computer" toggle in mSecure 5 on Mac or Windows

2. Restart the apps on all devices,

3. Have the app opened, unlocked, and in the main view on each device

4. Do a manual sync on the client device (iOS manual sync [requires at least one record]: tap and hold the top record > drag down > release)


Login or Signup to post a comment